Simulink Real-Time Explorer

Interact with target computer and real-time application running on target computer

Description

Simulink® Real-Time™ provides a single point of contact for configuring the development and target computers and interacting with a real-time application. You can monitor and trace signals, tune parameters, create and run instrument panels, and export and run an Explorer configuration as a standalone executable.

Note

Do not use Simulink external mode while Simulink Real-Time Explorer is running. Use only one interface or the other.

Use Simulink Real-Time Explorer for the following tasks. For examples, click the links in the More Information column.

Target Computer Configuration

CapabilityMore Information

Configure target computer communication parameters.

Configure target computer configuration settings.

Target Computer Settings

Configure target computer startup and create boot images for target computers.

Target Computer Boot Methods

Real-Time Application Access and Control

CapabilityMore Information
  • Connect target computers to a development computer, and then disconnect them.

  • Load a prebuilt real-time application into a target computer, and then unload it.

  • Start and then stop running a real-time application that you downloaded to the target computer.

  • Display execution time, task execution time, and other properties of the real-time application.

  • Change stop time and sample times without regenerating code.

Signal Access

CapabilityMore Information

Filter and group hierarchical signals

Display and Filter Hierarchical Signals and Parameters

Monitor signals.

  • Add host, target, or file scopes for the downloaded real-time application, and then remove them.

  • Add signals to scopes, and then remove them.

  • Configure scope properties.

  • Configure a host scope display and use it for viewing signal values.

  • Start and stop scopes.

  • Browse file scope output files on the target computer file system.

Create, save, and load signal groups.

Create Signal Groups with Simulink Real-Time Explorer

Parameter Tuning

CapabilityMore Information

Filter and group hierarchical parameters

Display and Filter Hierarchical Signals and Parameters

Display and tune parameter values while the real-time application is running.

Create, save, and load parameter groups.

Create Parameter Groups with Simulink Real-Time Explorer

Instruments and Instrument Panels

CapabilityMore Information

Create, configure, save, and load graphical instrument panels for acquiring signals and tuning parameters.

Attach parameters to instruments in instrument panels.

Attach signals to instruments in instrument panels.

Start and stop instrument panels and use them to interact with real-time applications.

Configure Scope instruments.

Explorer Configuration

CapabilityMore Information

Save and load environment properties, instrument panels, and Explorer configuration layouts.

Export Explorer configuration as a standalone executable.

Export Explorer Configuration

Run standalone executable generated from an exported Explorer configuration.

Unpack and Run Standalone Configuration

Windows

Simulink Real-Time Explorer provides tool windows and workspace windows in its main window. Tool windows include Targets, Applications, Scopes, Palette, Panels, Output, and so on. Workspace windows include windows for interfacing with the real-time application, setting environment properties, setting application and scope properties, and so on. You can resize tool windows and drag them by their title bar. You can drag workspace windows by their tab.

Layouts

To create optimal window layouts for your work, customize the position, size, and behavior of the various windows. When you customize the layout for the tool windows, Explorer retains the positions, size, and docking locations of each tool window. For example, assume that you change the docking location of the Targets tool window, and then close Explorer and MATLAB®. The next time that you start Explorer, the target tool window is docked in that same location. Workspace window customizations do not persist across different MATLAB sessions.

Tab Groups

To manage limited workspace while you are working with two or more Explorer windows, use Tab Groups. You can organize multiple workspace windows and tool windows into vertical and horizontal Tab Groups. You can drag windows from one Tab Group to another.

Arrange Tool Windows

You can dock tool windows anywhere within the main window, float them as separate windows independent of the main window, and hide them.

You arrange tool windows by dragging and dropping them or by right-clicking the window title bar and clicking a menu command:

  • Pin tool windows to the left or the right of the tab well.

  • Dock tool windows to the edge of the main window.

  • Float tool windows over or outside the main window.

  • Hide tool windows along the edge of the main window.

  • Display tool windows on different monitors.

  • Save window placement to a custom layout and restore it.

Arrange Workspace Windows

You can dock workspace windows anywhere to the left of the main window, float them as separate windows independent of the main window, and close them.

You arrange workspace windows by dragging and dropping them or by right-clicking the window tab and clicking a menu command:

  • Tile workspace windows in the tab well.

  • Dock workspace windows to the left edge of the main window.

  • Float workspace windows over or outside the main window.

  • Close workspace windows.

  • Display workspace windows on different monitors.

  • Save window placement to a custom layout and restore it.

Dock Windows with a Guide Diamond

When you click and drag a tool window title bar or a workspace window tab, a guide diamond appears. As you drag the window, place your cursor over one of the arrows in the diamond. A shaded area appears that shows where the window will appear after you release the mouse button.

To move a dockable window without snapping it into place, press the Ctrl key while you drag the window.

To return a tool window or workspace window to its most recent docked location, double-click the window title bar or window tab. You can fasten tool windows to one side of a frame in the main window. When you drag a tool window to another location, a guide diamond appears to help you redock the window.

Close and Auto Hide Tool Windows

You can close a tool window by clicking the X in the upper right of the title bar. To reopen the window, in the View menu, select the tool window that you want to reopen. If the tool window is closed, the tool window opens and becomes the active selected tool window. If the tool window is already open, it becomes the currently active tool window.

Tool windows support Auto Hide (), which causes a window to slide out of the way when you use a different window. When you autohide a window, its name appears on a tab at the edge of the frame of the main window. To use the window again, place your cursor over the tab or select the tool window from the View menu. The window slides back into view.

Create and Save Layouts

You can create and save a custom layout that includes workspaces that you created for a specific target computer and real-time application. You can then switch between layouts with a single command. If you open a layout that contains workspaces, the target computer must have the same application and resources as when you originally created the layout.

Restore Layouts

You can return Explorer to the original window layout for your settings by using the Restore layout command. When you run this command:

  • Tool windows move to their original positions.

  • Workspace windows that were previously opened close.

  • Workspace windows included in the layout that are open in the original layout open.

You can restore workspace windows that depend on a specific target computer and real-time application. The target computer must be connected and contain the same application and resources as when you created the layout. Windows that fail to open produce an error message in the output window

Representative Layout

The figure shows a representative layout showing several tool and workspace windows.

In this figure, the tool windows are:

  • Targets (top left) — Lists the targets in your Simulink Real-Time hierarchy. Under each target are nodes representing the properties and file system of the target.

  • Applications (middle left) — Lists the real-time applications running on the targets. Under each application are nodes representing the properties, signal and parameter groupings, and model hierarchy of the application. If a target is not running a real-time application, it does not appear in the list.

  • Scopes (bottom left) — Lists the scopes defined on the active real-time applications, whether predefined or dynamically created.

  • Output (bottom center) — Displays status and error messages.

  • Properties (bottom right) — Lists the properties of a selected instrument or layout element.

  • Panels (middle right) — Lists the instrument panels that have been loaded.

  • Palette (top right) — Lists the instrument and layout elements available for constructing instrument panels.

The workspace windows are:

  • TargetPC1/xpcosc/Scope 1 (Host Scope Viewer) (top center) — The host scope viewer window shows signal and time information from a host scope that is running on the target computer.

  • xpcosc (TargetPC1) (mid center) — The parameter window shows tunable parameters from the real-time application that is running on the target computer.

Exported Standalone Interface

You can export Simulink Real-Time Explorer as a standalone executable to a computer compatible with Windows®. You do not have to run MATLAB to run the standalone interface.

When you run Explorer as a standalone interface, it supports a subset of the capabilities that it supports under MATLAB.

  • You cannot change the communication parameters that the interface uses to communicate with the target computers. Before you export the Simulink Real-Time Explorer configuration, configure and test the communication parameters for each target computer.

  • For each instrument, the exporting software records the real-time application and target computer environment with which it is associated.

  • If you rename a target computer, to maintain the connection to the real-time application, update the TargetName parameter for each associated instrument.

  • You cannot load or unload a real-time application from the standalone executable. Before you start the executable, start the real-time application on the target computer.

  • You can access only instrument panels and windows that you loaded before you exported the configuration.

  • You cannot access the real-time application model hierarchy from the standalone executable.

  • You can access only signals in signal groups that you loaded before you exported the configuration.

  • You cannot move a signal from one signal group to another group, or create or load a new signal group.

  • You can access only parameters in parameter groups that you loaded before you exported the configuration.

  • You cannot move a parameter from one parameter group to another group, or create or load a new parameter group.

  • You cannot save session layouts. If you close a window, you can restore the original layout using File > Restore Original View.

Open the Simulink Real-Time Explorer

  • In the Simulink Editor, on the Real-Time tab, from the Prepare section, click SLRT Explorer.

  • On a computer compatible with Windows, click the standalone executable.

Programmatic Use

expand all

In the Command Window, type slrtexplr.

Introduced in R2014a