MATLAB Answers

0

What causes the error: "Could not append child which had existing parent" when trying to generate a report via Test Manager

Asked by Justin Mellor on 30 Jan 2017
Latest activity Edited by Abhishek
on 12 Apr 2017
The above is displayed via a dialogue box when trying to generate a report

  3 Comments

Can you explain with more details, what you try where with which Matlab release?
I had run a test sequence (Test Harness), via a test file with a blank test suite & a single test case with 2 iterations. The results were visible in the Test Manager Results and Artifacts window and the report started to generate. I think it got to about 60%. Version used is 2016b
Please create a service request for this issue here: https://mathworksservicerequest.secure.force.com/cp_case_new?cc=us
Please attach the reproduction steps with needed files, models etc. We will try to resolve this as soon as possible for you.

Sign in to comment.

1 Answer

Answer by Abhishek
on 12 Mar 2017
 Accepted Answer

Please take a look at this bug report: https://www.mathworks.com/support/bugreports/1545180
There is a patch attached to the bug report. It should fix the issue.

  2 Comments

Hi, using the 2016b version fix, the error message is now removed and the report generates but even though all the verify statements in the test pass the test report details a failure with the following message:- Simulation Error: An internal error has occurred. Restart MATLAB before proceeding. If this problem persists, please contact MathWorks.
This is because of a known bug in Simulation Data Inspector. Please see this bug report: https://www.mathworks.com/support/bugreports/1302441

Sign in to comment.