why evalin doesnt wotk in App Designer matlab 2017b?

11 views (last 30 days)
Kaustubh hike
Kaustubh hike on 1 Nov 2021
Commented: Rik on 2 Nov 2021
I am creating app in appdesginer .
When I ran the same code in same matlab version , it works but when I tried to implement it in app designer it gives error as
Undefined function or variable 'XXXX'.
What could be the reason or what could be the alternative for the same?
Rik on 2 Nov 2021
That was just an example function. Since you haven't explained anything about how you call your function I can't actually suggest the real changes you should make. You shouldn't be needing evalin. You should use input arguments to your functions.
If you don't know how to do that I suggest you do a basic Matlab tutorial.

Sign in to comment.

Accepted Answer

Bruno Luong
Bruno Luong on 2 Nov 2021
Edited: Bruno Luong on 2 Nov 2021
You probably forget to populate APP_isc_n_gbxInp in the base workspace.
I create a small app (attached) and evalin works just fine (R2021b)
>> clear
>> testevalin
Cannot retrieve a from base workspace % message when I click on "Get a button", not working since a is not created
>> a=1
a =
a = 1.000000 % message when I click on "Get a button", it woeks

More Answers (0)




Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!