MATLAB Answers

0

No more plot although no errors

Asked by Peter Groh on 28 Sep 2017
Latest activity Answered by Christopher Stapels on 14 Dec 2017
My Visualizations stopped displaying anything ( no plot) - it worked for months. Even taking the template "Create a 2-D line plot" I just get the the result " _ MATLAB code ran successfully_." and no error code in the output field - but still no plot.
Is there a problem with connecting to thingspeak or what has changed?
.
Here the simple code from the template:
% Template MATLAB code for visualizing data from a channel as a 2D line
% plot using THINGSPEAKPLOT function.
% Prior to running this MATLAB code template, assign the channel ID to read
% data from to the 'readChannelID' variable. Also, assign the field ID
% within the channel that you want to read data from to plot.
% TODO - Replace the [] with channel ID to read data from:
readChannelID = [139311];
% TODO - Replace the [] with the Field ID to read data from:
fieldID1 = [5];
% Channel Read API Key
% If your channel is private, then enter the read API
% Key between the '' below:
readAPIKey = '';
%%Read Data %%
[data, time] = thingSpeakRead(readChannelID, 'Field', fieldID1, 'NumPoints', 30, 'ReadKey', readAPIKey);
%%Visualize Data %%
thingSpeakPlot(time, data);

  1 Comment

Rik
on 28 Sep 2017
Are data and time empty? The reason for the absence of a plot can most likely be found inside either thingSpeakRead or thingSpeakPlot.
Have a read here and here. It will greatly improve your chances of getting an answer.

Sign in to comment.

1 Answer

Answer by Christopher Stapels on 14 Dec 2017
 Accepted Answer

As of December 14, your channel has recent values in it. I think the NaN values between real values are making the plot scale unexpectedly. Try adding a LineSpec For example, plot(timeA,dataA,'ro-');

  0 Comments

Sign in to comment.