MATLAB Answers

Simulink Startup Error shows Server Error

86 views (last 30 days)
Tzu Yang Loh
Tzu Yang Loh on 19 Mar 2018
Commented: Shravan Kumar on 1 Jun 2019
Hi, When I start my Simulink, it shows two errors
Task name: 'sltemplate.internal.request.loadTemplates' Task arguments: '' Error Type: 'Server Error' Error Message: 'Forbidden;403'
Task name: 'sltemplate.internal.request.loadSimulinkHistory' Task arguments: '' Error Type: 'Server Error' Error Message: 'Forbidden;403'
Any reasons and solution to this please? Thank You

  0 Comments

Sign in to comment.

Answers (2)

Pradeep Kumar
Pradeep Kumar on 14 Jan 2019
After uninstalling and reinstalling MATLAB thrice, I think I may have found a solution to this problem.
Let me first list out things that don't work:
  1. Reinstalling MATLAB
  2. Reinstalling MATLAB in a drive different than the original drive (D:\ instead of C:\ e.t.c.)
  3. Executing the commands listed in the above answer.
  4. Regenerating the MATLAB preference folder as instructed in the link provided in the above answer.
Now the solution is pretty simple. This error goes away if the internet connection is turned off when MATLAB/Simulink is opening.
The connection can be turned ON once simulink has opened successfully.
Although this is only a work-around, it seems to be the only way to get around this problem until MathWorks comes up with a solution.

  3 Comments

Pradeep Mp
Pradeep Mp on 19 Feb 2019
Thanks a lot bro. After struggling so many times to open simulink, I thought of uninstalling matlab. But after seeing your answer, I used your trick and it worked.
Pradeep Kumar
Pradeep Kumar on 23 Feb 2019
Great to know that it worked for you! Cheers.

Sign in to comment.


Sonam Gupta
Sonam Gupta on 28 Mar 2018
Execute the following commands in your MATLAB command window to resolve this issue:
restoredefaultpath
rehash toolboxcache
savepath
sl_refresh_customizations
If the above commands do not work then regenerating MATLAB preference folder by following the instructions at this link may help:

  1 Comment

Pradeep Kumar
Pradeep Kumar on 12 Jan 2019
This does not resolve the issue. I have tried regenerating the MATLAB preference folder as well, as directed by the above link. However, the problem still persists.
Please look into this issue at the earliest and provide a resolution.

Sign in to comment.

Sign in to answer this question.