MATLAB Answers

0

Error in Integrator is not finite

Asked by Mostafa Salam on 9 Sep 2018
Latest activity Answered by Robert
on 14 Dec 2018
I received the following error:
Derivative of state '1' in block 'PSO_PFL/Crane Model/Integrator1' at time 4.0 is not finite. The simulation will be stopped. There may be a singularity in the solution. If not, try reducing the step size (either by reducing the fixed step size or by tightening the error tolerances)
I try all previous answers but without positive result

  0 Comments

Sign in to comment.

Tags

2 Answers

Answer by Titus Edelhofer on 9 Sep 2018

Hi Mostafa,
interesting that the error happens at time 4.0. This could indicate, that indeed something happens in your model at t=4.0. Take a closer look at blocks which change their behavior at t=4.0.
I understand you tried the suggestions? Are you using variable or fixed step solver?
Titus

  0 Comments

Sign in to comment.


Answer by Robert
on 14 Dec 2018

Hi Mostafa,
use a relational operator block along with an assertion block to check that your integrator input is always finite. If not so, try to trace it back and fix it there to always be finite.
If the input is finite, there is the possibility you ran into a simulink bug that causes a completely wrong error message. I had a table lookup where the lookup data contained a nan-value. Whenever it had to use this value for interpolation, i got above error message for an integrator far away from the table lookup, even when i made sure a nan-output from the lut is never used by passing the output through a switch controlled by an isnan relational operator, replacing nan by a 1 in case. i corrected the lut data and the problem was solved.
Best regs,
Robert

  0 Comments

Sign in to comment.