SOLVED: Unable to Upload Firmware to Pixhawk; Firmware image not found

23 views (last 30 days)
See the bottom comment for the solution
I've been following the setup steps for the PX4 Autopilots Support from Embedded Coder package. I was able to succesfully build the firmware (nuttx_px4fmu-v2_default.cmake), however when trying to upload it to the actual board, I get the following error:
Firmware upload failed: Firmware image not found. Please build the firmware again.
I've rebuilt the firmware a dozen or so times now, including the lpe variant, and I always get this error. The COM port is properly identified, and I used the appropriate version for everything (Ubuntu 16.04 WSL, PX4 v1.8.0, MATLAB R2018b along with all required packages). In the command prompt it indicates
CMAKE Config selected : px4fmu-v2_default
After building the firmware. Any clue why this is happening/how to resolve it?
I'm running MATLAB on Windows 10 1803, using a Pixhawk board (condensed version of Pixhawk 1)

Sign in to comment.

Accepted Answer

Joshua O'Reilly
Joshua O'Reilly on 12 Jul 2019
Edited: Joshua O'Reilly on 5 Feb 2020
Copying my comment down here:
Got it to work!
It turns out that, if the firmware build fails, it won't tell you why. I ran the build command from here:
make px4_fmu-v5_default
(for the Pixhawk 4, seperate commands can be found for other models)
After running the make command, I was told exactly what library was missing (don't remember which anymore), and I installed that library directly from the command line (for ubuntu, sudo apt install libraryname). I was then able to build and upload the firmware successfully through MATLAB

More Answers (0)




Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!