Error in the plot function/low resolution

3 views (last 30 days)
Hi everyone!
I have an EMG signal at 1000Hz. When I use the plot(EMG signal), the x values only move at 10 ms (anything inside this gets the same x value), the y values are working fine (upper pic). If I cut the signal to a smaller piece, the error is gone (lower pic). I need the 1ms resolution to define events.

Accepted Answer

Pedro Valadao
Pedro Valadao on 9 Feb 2021
Hi all,
It is not an error. It is just the precision of the datatip function. It is easily adjustable on the following line:
formattedValue = [valueFormat num2str(value,4) removeValueFormat];
i found this info on the following discussion:
Cheers!
Pedro.

More Answers (2)

Maximilian Schönau
Maximilian Schönau on 5 Feb 2021
Hi, it is hard to find (and fully understand) your problem without having your code.
If I understand your question right, you want to be your upper plot in a better resolution. Since you have the data probably available in a better resolution (second plot), I would guess that some function deletes some values on the way, it could be for example the function linspace(x1,x2,resolution) which does this to your data.

Pedro Valadao
Pedro Valadao on 5 Feb 2021
Hi Max,
Thank you for the quick reply! The same error occurs with the following code:
v = rand(1,150000),plot(v) % here the error happens as in the upper figure
figure, plot v(1:200) % here the error does not happen as in the lower figure
I have checked multiple files with the same type of data, .mlx and .m - the same problem happens consistently.
Br, P.
  4 Comments
Pedro Valadao
Pedro Valadao on 8 Feb 2021
sorry if this is too much of a newby question, I'm tagging you because you have answered pretty much all questions I have seen in this forum! haha
Could you please help?
Br, Pedro.

Sign in to comment.

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!