Problem while running SIMULINK on Raspbery Pi B+using Matlab 2014a

2 views (last 30 days)
Hi all, I have followed the steps provided by mathwork and everything is file in connection. But when I tried to open simulink example I get the erorrs
>> raspberrypi_inversion Warning: Undefined variable "codertarget" or class "codertarget.updateExtension". Warning: Detected 1 error(s) in Simulink.ConfigSet.getDialogSchema: Undefined variable "Simulink" or class "Simulink.sta.FeatureControl.getFeature".
And when I click on tool-->Run on Target Hardware---> Option it gives following error:
Warning: Detected 1 error(s) in Simulink.ConfigSet.getDialogSchema: Undefined variable "Simulink" or class "Simulink.sta.FeatureControl.getFeature".
Cannot create config set dialog >>
I am unable to resolve this please help me out what is missing and how to resolve.
<<
>>

Accepted Answer

Sean de Wolski
Sean de Wolski on 17 Oct 2014
Sounds like a path issue:
which Simulink.sta.FeatureControl.getFeature
Should return something like
C:\Program Files\MATLAB\R2014b\toolbox\simulink\sta\ui\+Simulink\+sta\@FeatureControl\FeatureControl.p % static method or package function
Try running the following:
restoredefaultpath
rehash toolboxcache
This should resolve it.

More Answers (1)

Florian Dignath
Florian Dignath on 20 Jul 2017
Hi,
I get exactly the same error as desribed here, when clicking on the "Model Configuration Parameters" Button in Simulink (Windows 7, Matlab R2014a). I installed R2014a completely new and still got the same error on a new, empty Simulink model.
When I use "restoredefaultpath, rehash toolboxcache" as suggested here, everything works fine! However, whenever I restart Matlab, the error returns. Even though, I use "save path" and don't edit anything else.
Is there a way of preventing this error permanently?

Categories

Find more on MATLAB Coder in Help Center and File Exchange

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!