S-function does not exist error in Simulink MATLAB

16 views (last 30 days)
I am trying to run a model in SImulink Matlab that uses both Matlab based S-function block (a .mexw32 file) and a C code based S-function block (a .c file). When I run the model, I get the error below:
I don't know why it keeps saying "It does not exist". The file is there, and it does exist. Someone should please help me out here. See the files in one folder below:
I also downloaded and installed MATLAB support for MinGW-w64 C/C++ Compiler to compile the C code so that it can be called from MATLAB using MEX. I'm still getting the same error despite doing this. I don't know what else to do.

Answers (1)

Aditya Jha
Aditya Jha on 17 Jan 2023
Hi!
Simulink needs the s-function to be compiled into a mexw64.Please find the below MATLAB answers post with similar query: https://www.mathworks.com/matlabcentral/answers/735042-s-function-does-not-exist-but-is-clearly-in-the-matlab-path

Categories

Find more on Simulink Coder in Help Center and File Exchange

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!