Clear Filters
Clear Filters

Getting error from xlsread

45 views (last 30 days)
Armin Sadeghian
Armin Sadeghian on 17 Feb 2016
Commented: Kashif Mehmood on 25 May 2019
I am trying to run a code which used to work perfectly using previous versions of Matlab. Now after upgrading to version 2015b I receive this error at line 251 of xlsread.m
Anybody knows anyway to fix this?
thank you.
ravi on 11 Apr 2016
I was encountering the same problem since long. I tried saving the excel file in 97-2003 format. And then xlsread worked well :-)
Kashif Mehmood
Kashif Mehmood on 25 May 2019
i tried this but still have problem

Sign in to comment.

Accepted Answer

xianjie Zhou
xianjie Zhou on 17 Feb 2016
What error message you got? I have the same problem, it saids: Error: The server threw an exception. But I run for second time it goes. I believe there are some solutions for that:
  1 Comment
Armin Sadeghian
Armin Sadeghian on 17 Feb 2016
When I check xlsread.m at line 251 I see the same error "threw exception".I reinstalled Matlab, but it did not solve my problem.

Sign in to comment.

More Answers (3)

XM Liu
XM Liu on 17 Nov 2016
1- open the excel> file, >option, >add in, manage then select COM ADD IN, and clear everything (unchecked). everything should be cleared (unchecked). 2- restart the PC, and open the matlab. 3- perform xlsread command.
PS. For those people who use foxit pdf reader, it is potential to face this problem, so follow mentioned order.
An on 12 Nov 2018
Also worked for me. Such a weird bug with Foxit... Thanks XM Liu!
Atsushi on 30 Apr 2019
Thanks Liu. It also worked for me with R2018a and Excel 2016.

Sign in to comment.

vcmorini on 16 May 2017

Seth Wright
Seth Wright on 22 Oct 2018
Saving it as a csv file fixed it


Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!