MATLAB Answers

AppDesigner .mlapp save r2016a compatible version from r2017a

9 views (last 30 days)
Michael L
Michael L on 19 Jul 2017
Edited: Melissa Williams on 24 Jan 2018
Hi, I've developed a mlapp in R2017a. However, I can not open (to edit) on R2016a. It says "Error loading .mlapp". How can I save a backwards compatible mlapp?
Open the app to run works fine.

Accepted Answer

Faiz Gouri
Faiz Gouri on 21 Jul 2017
It is not recommended to open App Designer app created with MATLAB R2017a in previous releases as it may have new features introduced in R2017a. Refer the release notes here
Follow the workaround provided on this page to open the mlapp file in R2016a.
  1 Comment
Michael L
Michael L on 3 Aug 2017
Thanks! I did not realize how new AppDesigner was. I had to force a few of my coworkers to update to 2017a. Hopefully MATLAB keeps developing more features into AppDesigner! In my humble opinion, it's easier to work with than GUIDE.

Sign in to comment.

More Answers (1)

Melissa Williams
Melissa Williams on 24 Jan 2018
Edited: Melissa Williams on 24 Jan 2018
Hello, To work around this issue please see this bug report which gives you instructions on how to patch R2016a.
-Melissa

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!