license error -5,357

29 views (last 30 days)
Pebby Garner
Pebby Garner on 25 Sep 2017
Commented: Walter Roberson on 2 Oct 2018
I am trying to add a child license to an individual license. This was converted from a concurrent license. I uninstalled MATLAB and then reinstalled it. I'm still getting the same error.
>> license checkout Simulink_Coder
License checkout failed.
License Manager Error -5
Cannot find a license for Simulink_Coder.
Troubleshoot this issue by visiting:
http://www.mathworks.com/support/lme/R2014b/5
Diagnostic Information:
Feature: Simulink_Coder
License path: C:\Users\iob391\AppData\Roaming\MathWorks\MATLAB\R2014b_licenses\license_RR166696IP01_40537855_R2014b.lic;C:\Program Files (x86)\MATLAB\R2014b\licenses\license.dat;C:\Program Files (x86)\MATLAB\R2014b\licenses\trial_4347790_R2014b.lic
Licensing error: -5,357.
ans =
0
There are licenses in each of the paths except one -- C:\program files (x86)\MATLAB\R2014b\licenses\license.dat
I have attached both license files.
Could you please help in getting these licenses to read properly?
Thank you.
  2 Comments
Walter Roberson
Walter Roberson on 25 Sep 2017
Please contact Mathworks for free license assistance.

Sign in to comment.

Answers (4)

Angela Dixon
Angela Dixon on 30 Sep 2018
Licensing error: -5,357 We are a BEST robotics team. We are getting the above licensing error. We do not know why we get this error. Also, license error -5. Our software has been properly activated. We have uninstalled and reinstalled the software but still get this code when we deploy the code to our vex cortex. Please help us understand how to fix this error. We did download the FMU tool box coactivator but that did not change the error code.

Walter Roberson
Walter Roberson on 1 Oct 2018

Angela Dixon
Angela Dixon on 1 Oct 2018
We do have a license. It was verified when the program was activated. After reading these codes, I still do not understand what to do.
  1 Comment
Walter Roberson
Walter Roberson on 1 Oct 2018

Activation creates and installs a license file for the products that are covered by your license.

Error -5 is something you get when you have a product installed but it is not covered by your license (or in some cases due to misconfigured license server.)

You mention that you get the error when you attempt to deploy to your vex cortex. That suggests that you do not have a license for one of the following:

    MATLAB
    Simulink
    MATLAB Coder
    Simulink 3D Animation
    Simulink Coder
    Stateflow

Depending on exactly what you ask to do, you could also be missing a license for one of

    Simscape
    Simscape Multibody

Sign in to comment.


Angela Dixon
Angela Dixon on 1 Oct 2018
We downloaded the program per the instructions from MATLAB through BEST Robotics - how can I find out what I do and do not have a license for? I am just a high school teacher (biology), not an IT manager. I am feeling rather clueless here.
  4 Comments
Walter Roberson
Walter Roberson on 2 Oct 2018
Ah, thanks for the explanation!

Sign in to comment.

Products

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!