MATLAB Answers

libmwlmgrimpl.dll error in R2017b

116 views (last 30 days)
Maxime Plante
Maxime Plante on 25 Feb 2018
Commented: Maxime Plante on 1 Mar 2018
I am trying to run a Matlab function compiled with Matlab Compiler SDK. The code is in a docker container along with the Matlab runtime (R2017b). The function is doing a simple addition.
When I run the code, I get the following error:
Fatal Internal Error: std::exception: Bundle#4 start failed: Loading C:\Program Files\MATLAB\MATLAB Runtime\v9 4\matlab_startup_plugins\lmgrimpl\libmwlmgrimpl.dllfailed with error: The specified module could not be found.
I found this link that mentions this bug, but it was solved in R2017a.
I also found this link, but it does not have the same error message. Additionally, I am not able to find the LIBEAY32.DLL and SSLEAY32.DLL in the matlab runtime executable (once decompressed).
Do you have any pointers for things to try? Thank you.
NB: I am using a student license provided by my University.

  0 Comments

Sign in to comment.

Answers (1)

Chandani Madnani
Chandani Madnani on 1 Mar 2018
Edited: Chandani Madnani on 1 Mar 2018

  1 Comment

Maxime Plante
Maxime Plante on 1 Mar 2018
The compiled Matlab code is actually a Python library compiled with Python Compiler SDK. Where should I put the executable since there is not executable file? Thanks!

Sign in to comment.

Sign in to answer this question.

Tags