Error using load. Can't read file <filename>.

8 views (last 30 days)
jj on 26 Jun 2012
Hi guys,
I have tried to search on google, and within this forum before deciding to post. I have been trying to save a workspace that is approximately 5gb large. It's huge, but it is important that I save all the variables generated by the matlab code I have. It takes approximately 17 hours for my code to finish its run. So, it's been really frustrating to keep re-running the program, without the ability to save all the result variables.
After the results are out, I am able to successfully save the workspace as a .mat file. However, when I tried to load the results .mat file, it says there is an error using load, and Matlab can't read file.
Is there a way to solve this problem? How else can I successfully save and load a program? I am using a 64bit, 8gb ram computer.
Belgacem on 8 Jan 2013
I have the smae issue Matlab version V7.3

Sign in to comment.

Answers (1)

Jan on 8 Jan 2013
Please post the version of the MAT file format. See help save. Try:
save(FileName, 'Data', '-v7.3');

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!