MATLAB Answers

Error with Embedded Coder Quick Start for AUTOSAR

8 views (last 30 days)
I tried to generate code from AUTOSAR model. but I'm not successful it. it has occurred error. I don't know what occurred the problem that. the following text is error log.so... please help me?
Error: Error occurred when generating shared type: Type, 'BoostCurveStructType', is specified to export to a header file, but compact file format has been requested. Either select a different file packaging format or do not select the 'Export' option for the data type.
I'm trying that, make to look up table and type to script referring of look up table class.
LUTObj.Table.DataType = 'double';
LUTObj.Breakpoints(1).DataType = 'double';
LUTObj.Breakpoints(2).DataType = 'double';
LUTObj.Table.FieldName = 'TorqueMap';
LUTObj.Breakpoints(1).FieldName = 'Angle';
LUTObj.Breakpoints(2).FieldName = 'Speed';
%
%
LUTObj.CoderInfo.StorageClass = 'ExportedGlobal';
LUTObj.StructTypeInfo.Name = 'BoostCurveStructType';
LUTObj.StructTypeInfo.DataScope = 'Exported';
LUTObj.StructTypeInfo.HeaderFileName = 'BoostCurveStructType.h';
open_system('Bsts')
load_system('Bsts')
set_param('Bsts/ReEscController_sys/Boost Curve',...
'DataSpecification','Lookup table object',...
'LookupTableObject','LUTObj')
but
when I command that rtwbuild, it has occurred the problem.

  0 Comments

Sign in to comment.

Accepted Answer

KOOKMIN UNIV
KOOKMIN UNIV on 3 Oct 2018
I have the successful task. the problem is simple.
the following code is successful it
LUTObj.Table.DataType = 'double';
LUTObj.Breakpoints(1).DataType = 'double';
LUTObj.Breakpoints(2).DataType = 'double';
LUTObj.Table.FieldName = 'TorqueMap';
LUTObj.Breakpoints(1).FieldName = 'Angle';
LUTObj.Breakpoints(2).FieldName = 'Speed';
LUTObj.CoderInfo.StorageClass = 'Auto';
LUTObj.StructTypeInfo.Name = 'BoostCurveStructType';
LUTObj.StructTypeInfo.DataScope = 'Auto';
LUTObj.StructTypeInfo.HeaderFileName = 'Rte_Type.h';

  0 Comments

Sign in to comment.

More Answers (0)

Sign in to answer this question.