MATLAB Answers

Audio plugin not compiling after update to Xcode 11.4

8 views (last 30 days)
Barry Dean
Barry Dean on 8 Apr 2020
Answered: Jimmy Lapierre on 6 Jan 2021
The following command is now generating a compile error after I updated Xcode to 11.4
generateAudioPlugin -au audiopluginexample.Echo
macOS version 10.15.4
Command Window Output (first section)
//////
Error using generateAudioPlugin
Xcode build failed:
2020-04-08 17:55:20.115 xcodebuild[985:20402] [MT] PluginLoading: Required plug-in compatibility UUID C80A9C11-3902-4885-944E-A035869BA910 for plug-in at path
'~/Library/Application Support/Developer/Shared/Xcode/Plug-ins/Unity4XC.xcplugin' not present in DVTPlugInCompatibilityUUIDs
2020-04-08 17:55:20.115 xcodebuild[985:20402] Failed to load plugin at: /Users/barrydean/Library/Application
Support/Developer/Shared/Xcode/Plug-ins/Unity4XC.xcplugin, skipping. Reason for failure: *** -[__NSPlaceholderDictionary initWithObjects:forKeys:count:]: attempt
to insert nil object from objects[0]
//////
Thanks
Barry
  2 Comments
Jimmy Lapierre
Jimmy Lapierre on 26 May 2020
This is an issue that will be fixed in upcoming releases/updates.

Sign in to comment.

Answers (1)

Jimmy Lapierre
Jimmy Lapierre on 6 Jan 2021
The list of supported compilers can be found on this webpage. Either click the "Mac" tab for supported Xcode versions, or for previous versions, click "View compiler support for previous releases" (there is a column for supported compilers).
  • Versions R2019a and earlier do not support Xcode 11.x for plugin generation.
  • Versions R2020b and earlier do not support Xcode 12.x for plugin generation.
Plugin generation with Xcode version 11.4 was supported out of the box in R2020b. For R2020a and R2019b, make sure to have applied the latest updates, as compatibility was added after the release of 11.4.

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!