Clear Filters
Clear Filters

.m module cached in Jupyter notebook environment

2 views (last 30 days)
I am using jpyter notebook with matlab engine running in the environment. I have a directory of .m files which I import using
addpath(my_folder);
I need to make a change to one of the files in this my_folder directory. However, everytime I ran my notebook, it still loads the old version. Even when I rename the entire directory, it still finds the old one.
I tried various techniques I found such as clear, rehash, modify using Matlab gui. nothing worked. Please tell me how to get my jupyter notebook to flush the cache and pick up the new .m file.
  4 Comments
Walter Roberson
Walter Roberson on 6 Jun 2021
Have you experimented with using "clear" and the name of the file being modified (without the extension) ? That should remove any caching of the file.
Bruce Ho
Bruce Ho on 6 Jun 2021
yes you can see in my original post, that I have tried clear.

Sign in to comment.

Answers (1)

Shubham Khatri
Shubham Khatri on 1 Jun 2021
Hello,
To my understanding you are trying too many things related to MATLAB. I would recommand you to just try to restarting jupyter service and try again.
Hope it helps
  1 Comment
Bruce Ho
Bruce Ho on 6 Jun 2021
no sir. I certainly have tried that multiple times. Has anyone actually done this successfully?
I don't think "trying too many things related to MATLAB" is any thing more than your opinion. I do these things because they are needed in my environment.

Sign in to comment.

Categories

Find more on Integration with Online Platforms in Help Center and File Exchange

Tags

Products

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!