MATLAB and Simulink Requirements

Product Requirements & Platform Availability for HDL Verifier

Supported Platforms

Windows, Linux

Product Requirements

  • Requires MATLAB
  • Simulink recommended
  • MATLAB Coder required for DPI component generation
  • Simulink Coder required for DPI component and TLM generation from Simulink
  • Fixed-Point Designer required for cosimulation and FPGA-in-the-loop

Supported Third-Party Compilers

Windows

  • MinGW 5.3 C/C++ (Distributor: mingw-w64)  (available at no charge)
  • Microsoft Visual C++ 2015 Professional
    • A compiler is not installed by default with this version of Visual Studio and must be specified while performing a custom installation. See Answer 328432 for more details.
  • Microsoft Visual C++ 2013 Professional
  • lcc-win64 (included with products that support it)

Linux

  • C/C++:
    • Java Development Kit (JDK) 1.8  (available at no charge)

Other Requirements

Introduced in R2012a

View requirements for another product: